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Introduction

This document describes how to download, install and use CLO API/SDK and
how developers can implement their own plug-ins running on CLO. It also
includes the simple structure for API/SDK package and addresses for the
sample projects in the package.

As CLO S/W has been developed for cross-platforms: Windows and Mac OS,
you can use the API/SDK package to make plug-in .dll and/or .dylib for both
platforms.

They have commonalities but some parts are different. Will describe the
common parts and different parts respectively.

Installation
1) System Environment
a. Windows

- OS: Windows 8, Windows 10
- IDE: Visual Studio 2017 (or above)

b. Mac OS

- 0OS: mac OSX 10.12 (or above)
- IDE: Xcode 9.2 (or above)

2) Download SDK

Please download the SDK zip file from the online manual.



https://support.clo3d.com/hc/en-us/articles/360017616633?flash_digest=36d1dd5e923f53f4e80c61fdf48d2a92f0ddf31d
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3. CLO SDK Package

CLO SDK package includes API interface header/lib files and sample
projects.

1) Folder structure

- API/SDK Package

i ™y

Package

hS "y

4{ CLOAPIInteface ‘

—‘ include ‘
—‘ Lib ‘
~{ Samples ‘

— ExportPlugin ‘

“— LibraryWindowlmplementation
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2) API/SDK Package

a.
i.

CLOAPIInterface folder
<api_sdk_package>

i) CLOAPIInterface.h
This file includes all the header files for interface classes located in
the ‘include’ folder. You can include this file to use API calls inside
the interface classes. The usage is described in the Samples ->
ExportPlugin.

i) LibraryWindowlInterface.h
This file includes an interface class so that the plug-in developers
can override to implement the Library Window construction. You
can find the sample code for the usage via APl -> Samples ->
LibraryApilmplementation

include

i) CloApiData.h
This file includes some structures/classes for API calls.

i) DefineDIIForWin.h
This file contains a ‘define’ for export/import dll.

i) ExportAPlInterface.h, ImportAPlInterface.h
You can include this header file to import/export files such as ZPrj,
ZPac, OBJ, Rendering images, and so on. You can find the
example in “ExportPlugin” sample.

iv) FabricAPlInterface.h
You can include this header file to import metadata to add fabric
and/or export zfab file.

V) RestAPlInterface.h
This includes high-level wrapping functions of REST APIs. If these
are not enough for your own use, you may use your own REST
API functions.

Vi) UtilityAPlInteface.h



Lib

SY
()
NN

This file includes some utility functions like “Get temporary folder
path of CLO” and “Show a message box on CLO”.

This folder has library files for function table in the CLOAPIInterface
project: CLOAPIInterface.lib for Windows or libCLOAPIInterface_.dylib for
Mac OS. You should import this library file into your plug-in project to run
in CLO API functions inside CLO S/W.

iv. Samples

ExportPlugin

A sample project to show how to use Export APIs and create a
plug-in. For example, you can see how to save files such as
thumbnail and Tech Pack and send them to your server using
REST APIs with this project file.

LibraryWindowlmplementation

A sample project to show how to implement the custom Library
Window to build up the Finder API tab. You can find the usage
from 7. Library Window Implementation
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4. Quick Start

1) Download and install the “CLO 6.1.346 or later” into your PC via the CLO
Official Site (https://www.clo3d.com).

2) Open the sample project — ExportPlugin project

a.

Windows

Build “ExportPlugin.dll” file

Open the solution file (ExportPlugin.sin) via Visual Studio 2017 (or
above).

Run “Build Solution” in Visual Studio (press Ctrl+Shit+B for
shortcut). Make sure that “Solution Configurations” is “Release” and
“Solution Platforms” is “x64” when building the solution.

The DLL file will be created in “Samples\ExportPlugin\x64\Release”
folder.

Put “ExportPlugin.dll” into the default plug-in folder.

Copy the plug-in dll file and paste/overwrite into the assets folder;
located in “C:\Users\Public\Documents\CLO\Assets\Preference-
s\API_Plug_inV’

You can use the ‘cloapi_plugins’ folder as you used in the beta
version of API/SDK packages. Create ‘cloapi_plugins’ into the CLO
Executable folder you installed in i) and use it as the default plug-in

@ CLO_SDK_G..12_11.docx ExportPlugin > = ExportBOM.xcodeproj
Header > LibraryApilmplementation » ExportPlugin.sin
Lib > Source
Samples >

ExportBOM.xcodepro,

folder.

Mac OS

Build “libExportBOM.dylib” file

Open the xcode project file (ExportPlugin.xcodeproj) via Xcode.


https://www.clo3d.com/
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@ Xcode File Edit View Find Navigate Editor Debug Source Contro
{ JON > it ExportBOM ) I My Mac

B = Q A © = b B3 e ider ) h
Analyze +8B
Archive

v @ ExportBOM

v Header
ExportPlugin.h Build For
v [ Source Perform Action

o+ ExportPlugin.cpp d
Bui

Clean
Stop

v Products
TR libExportBOM.dylib

Scheme
Destination

Create Bot...

- Run “Archive” via Product menu in XCode.

@ Xcode File Edit View Find Navigate Editor Product Debug Source Control m Help

o0 e | 2 i ExportBOM ) Bl My Mac Minimize %
Zoom

B QA & =p 38 g < & ExportBom Header ) I |
v & ExportBOM
v [ Header
m ExportPlugin.h
v (7] Source

revious Tab

D ion and API %
Welcome to Xcode 88
Devices

Organizer

¢ ExportPlugin.cpp
v Products

i, libExportBOM.dylib Show Touch Bar

Bring All to Front
v & ExportBOM — h ExportPlugin.h

- You'd be able to find the output dylib via Window -> Organizer.

ii. Put “libExportBOM.dylib” into the default plug-in folder.

- Copy the plug-in dll file and paste/overwrite into the assets folder;
located in “~Documents\clo\Assets\Preferences\API_Plug_in\”

3) Run CLO and browse the new feature from plug-in menu.

Help
Language 4

User Settings - V|

Plug-in 4 Export Garment Information

Log Out
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5. Make your Own Plug-in

To make your own plug-in, you need to customize the following functions.
You can find these functions inside ‘ExportPlugin’ project.

1) DoFunction

This function is called when a user clicks the action menu in the CLO S/W
plug-in menu. In this function you can implement codes like sending exported
files to your server.

2) GetActionName
You can change the action menu title which appears under the plug-in menu.
3) CallbackFromWebKit(int argc, char** argv)

You can write the code for the call back function which will be called after
‘Browser Window' is triggered by Java Script code when using Web API. You
will be able to get the number of messages from ‘argc’ as integer and each
message from ‘argv’ as char* array via Web API sent from Java Script code
on your Webpage.

4) GetObjectNameTreeToAddAction

This function is called when the user adds a plug-in dll(or dylib) file into the
CLO S/W. You can manage the position where you want to put the plug-in
menu above or below which menu/action in the application. See “8. Plug-in
menu position” for details.

5) GetPositionindexToAddAction

This function is also used when the user imports a plug-in dll(or dylib); you
can choose whether the plug-in action would be put into below the designated
menu/action which you wrote in 4) or above the target.

Then, build DLL(or dylib) and paste it to the installation folder as guided in “4. Quick
Start”.

% Note. If you rename the plugin file and put the file on the designated folder, CLO
will run the plug-in just after completing the start-up of the application.

- Windows : “StartupPlugin.dll” into the executable folder,
- MacOS: “libStartupPlugin1.0.0.dylib” into the framework folder in the app package.
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6. Plug-In Manager

1) You can set the position to add a plug-in action into the desirable menu in the
User Settings via User Settings -> Plug-in Tab.

| Plug-in

Featre

Export Custom

2) If you click the B ada icon, ‘File Open’ dialog will be shown to input the
plug-in dll path for Windows, the dylib path for Mac OS and then ‘Register
Plug-in’ dialog will appear; you can edit the feature title and menu position to
insert the plug-in feature.

B rlug-in Manager ? X

Mams Export ::u:-t-:rr|
“oztion Flug-In

Export Custom
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3) New item will be added into the Preference Plug-In tab like below. You can
edit / delete the items.

User Settings

| Plug-in

Feabre

¥ In case you want to use the plug-in via the manager, please keep in mind
you should not use the default plug-in because it can cause malfunctioning of
CLO plug-in or the misconception of use.

11
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Library Window Implementation

Library Window Interface are different from the export plug-in. When the user
clicks ‘API tab’ in the Finder in CLO, the application starts to call the virtual
functions in the Library Window API interface class. If you implemented a
class inherited from the Library Window API interface class, build it, and put
the dll into CLO’s executable folder as designated way; the module will run
the implemented function inside the plug-in dll.

Windows

Open the sample project

Browse <api_sdk_package> - ‘CLOAPIlInterface’ -> ‘Samples’ ->
‘LibraryWindowlmplementation‘ and open the solution file:
“LibraryWindowlmplementation.sin”.

Write Code

You can write code as you want in LibrarylmplePlugin class functions in .cpp
file but do not add or modify anything inside .h file. Please see the 2) Mac OS
in this chapter for the codes.

Set Qt path
- Download Qt 5.14.2 library from https://www.qt.io/download-gt-installer

- Make sure to click “Deselect All” button when you come to select component
window. Click Qt 5.14.2 and then open up the Qt 5.14.2 tab to click MSVC
2017 64-bit.

Default Select All Deselect All

Select Package Categories []ats.150 ~
[ Archive v @] grs.a4.2
[ webassembly
LLTs ] msvc 2015 64-bit
Latest releases D MSVC 2017 32-hit
[ Preview MSVC 2017 64-bit
i ] MinGW 7.3.0 32-bit
G [ MinGW 7.3.0 64-bit
M1 InAM ADRMAT FRACAVH™ INAEY

- In order to use the Qt, we need to install Qt VS Tools extension in Visual
Studio. Click Tools -> Extensions and Updates then search for Qt Visual
Studio Tools.

- Once Qt Visual Studio Tools is installed, Qt VS Tools tab will appear on the
top of visual studio. Click Qt VS Tools -> Qt Options -> Add (search and add
Path where gmake is located) -> OK -> default Qt/ Win version: 5.14.2 -> OK

12
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d. Deploy Sample Assets
- Get the sample assets for the Library Window Implementation from

https://s3.amazonaws.com/Outside Work/CLO API/2 7/sample assets.zip or
https://clo3d.oss-cn-shanghai.aliyuncs.com/web/CLO API/2 7/sample assets.zip

Extract the sample assets into ‘C:/sample_assets’

e. Build the project

Build a solution/project then the output dll file will be created in
LibraryWindowlmplementation -> x64 ->Release folder named
CloLibraryAPI_Plugin.dll. Copy the output dll file into the CLO executable
folder. ‘APl tab’ in Finder will act as you described in your code following the
Library Window Interface/Implementation specification.

Please see the LibraryWindowlnterfacel.h and LibraryWindowimplmentation
Plugin project code for detalils.

2) Mac OS

e This will break apple Code Signs and/or Apple Notarization
e This example assumes that the ID of the user logged in to mac is
“current_user”

a. How to install Qt SDK

i. Download Qt mac sdk from https://www.qt.io/download-thank-you

13
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ii. Install the downloaded Qt to the default folder

iii. Symbolic Link

In -s ~/(at installed folder)/5.14.2/clang 64/ /usr/local/lib/OT

iv. Register QTDIR in .bash_profile.(If zsh, register.zsh_profile)

open ~/.bash_profile
export QTDIR=/usr/local/lib/QT

export PATH=$QTDIR/bin:$PATH
source ~/.bash_profile (or source .zsh_profile)

b. How to implement Library Window Implementation
I Extract the CLO_SDK.zip file.

CloApi >
[T CloLibraryAPI_Plugin.pro
Q CloLibraryAPI_Plugin.xcodeproj

mac_release

scripts

il. In the terminal, enter the following command to create
CloLibraryAPI_Plugin.xcodepro;j.

python scripts/build_libraryapi.py xdebug

14
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iii. Open the generated xcodeproj file in Xcode.

71 libCloLibr..yAPI_Plugin ) Bl My Mac  CloLibraryAP|_Plugin: Ready | Today at 5:11 Pl 1 = @ <0
B-)m)m)m)m)su piPlugincpp ) (] LibraryAPlImpIPlugi <n> ne
Identity and Type
namespace CLOAPI
{ Name LibraryAPlimplPlugin.cpp
LibraryAPIimplPlugin: :LibraryaPIImplPlugin{ ) Tyse Defoult - Co+Source [
{
v [ LibraryApiimplementation Location _Relative to Project <]

¥
o LibraryAPlimp/Plugincpp M
¥ 0 Headers. ibraryAPIImplPlugin: :~LibraryAPIImplPlugin()
» L CloAp! { Full Path
¥ i Sources (qmake] s CloApi/Samples|
& CloLibraryAPL_Plugin.pro LibraryAglimplementation/
N bool LibraryAPIImplPlugin::EnableCustomUI() iyt e i s
1
T T On Demand Resource Tags
}

Target Membership

= folderPath.section(' /', -1);
ath = folderPath.left({folderPath.size() - (filename.size() + 1)); OO e@a
tPath;

Qstring GetOnlyFileName(cons
€

estringd path)

Unit Test Case Class - A class

V. Edit the LibraryWindowImplPlugin.cpp file.
Always modify the next return value in the function to true.
The API tab is activated in the library window only if the return value of
this function is true.
Please set USE_LIBRARY_WINDOW_CUSTOM_TAB to 1.

bool LibraryWindowImplPlugin::EnableCustomUI()
{
#if USE_LIBRARY_WINDOW_CUSTOM_TAB
return true;
flelse
return false;
#endif

}

V. You can set the tab name in Library Window

string LibraryWindowImplPlugin::GetTabName()
{

string str = "Sample";

return strj;

Vi. If you need to set the API tab as default and move to the first tab, set
the ‘IsDefaultTab()’ as true. You can modify the macro,
“USE_CUSTOM_TAB_AS_DEFAULT’ to 1 to set the API tab as
default.

15
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bool LibraryWindowImplPlugin::IsDefaultTab()
{
#if USE_CUSTOM_TAB_AS_DEFAULT
return true;

#else
return false;
#endif
}
vii.  The currently implemented code is a sample code.

Implement functions declared in LibraryWindowlInterface.h to suit your
requirements.

Viii. Release build.

python scripts/build_libraryapi.py release

IX. The built dylib file will be created in the following location:

mac_release/CloLibraryAPI_Plugin/libCloLibraryAPI_Plugin.1.0.0.dy
lib

I S libCloLibraryAPI_Plugin. 1.0.0.dylib
Makefile »  libCloLibraryAPI|_Plugin.1.0.dylib
s libCloLibraryAPI_Plugin.1.dylib
»  libCloLibraryAPI_Plugin.dylib

1 moc »
¥ object >
aze » [l Documents » i CLO_SDK v0.8 for 5_0_OBT » [y mac_release » [l CloLibraryAPI_Plugin » [B build

16
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Overwrite the generated libCloLibraryAPI_Plugin.1.0.0.dylib file into
the CLO package installed in /Applications:

/Applications/CLO_Network_OnlineAuth_Beta.app/Contents/Frame
works/libCloLibraryAPI_Plugin.1.0.0.dylib

> Breakpad.framework >
> files.sign
> libavcodec.56.26.100.dylib
libavformat.56.25.101.dylib
> libavutil.54.20.100.dylib

libcgauth.dylib
>
> libCloMathSimulate.dylib

libCloScene.1.0.0.dylib

libcrypto.1.0.0.dylib

libcryptopp.dylib

libcurl.4.dylib

libfbxsdk.dylib

libfreeimage.3.16.0.dylib libCloLibraryAPI_Plugin.
libfreetype.6.dylib 1'0'0‘dy|ib
libftgl.2.1.3.dylib 1
libgee_s.1.dylib Ye%terday
libGLEW.2.1.0.dylib Yesterday
libgomp.1.dylib Yesterday
libnvrtc-builtins.dylib Add Tags...
libnvrtc.dylib

libomp.dylib

libopencv_core.2.4.11.dylib
libooencv hiahaui.2.4.11.dvlib

& Macintosh HD > Applications > ' CLO_Network_OnlineAuth_Beta.app > Contents > Frameworks > libCloLibraryAPI_Plugin.1.0.0.dylib

Get the sample assets for the Library Window Implementation from
https://s3.amazonaws.com/Outside Work/CLO API/2_7/sample_assets.zip Or
https://clo3d.0ss-cn-
shanghai.aliyuncs.com/web/CLO_API/2_7/sample_assets.zip

Extract the sample assets into ‘/Users/current_user/sample_assets’.

Set the sample assets folder described in the ‘APIDefine.h’ to
‘/Users/current_user/sample_assets’

APIDefine.h

const QString SAMPLE_STORAGE_DIRECTORY =
QString(“/Users/current_user/sample_assets/”

Now run CLO_Network_OnlineAuth.app.
Closet and API tabs will be created and shown on the left side of
Favorites in the Library window.

17
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File Edit 3D Garment 2D Pattern Sewing Materials Avatar Render Display

Library
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%

xv.  Click the API tab to navigate to the code you've implemented.

18
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Plug-in Menu Position
“cloapi_plugins” folder

When CLO S/W starts to run, the plug-in module loads the dll(or dylib) files in
the ‘cloapi_plugins’ folder automatically.

In case GetObjectNameTreeToAddAction() function is implemented and the
default position for the plug-in menu is described inside the function properly,
an action will be added to above or below the menu/action position for the
plug-in action.

If GetObjectNameTreeToAddAction() is not implemented or contains
improper description, an action will be added to the child of Settings / plug-in
menu.

Edit

The user can modify the target position for the plug-in menu when or after
adding the plug-in via the Plug-in manager. See “6. Plug-in manager”.

Add plug-in via Plug-in manager

If the plug-in dli(or dylib) has the proper GetObjectNameTreeToAddAction()
function, the position will appear in the Register Plug-in dialog so that the
user can edit and/or confirm.

Edit the plug-in action position

The user can change the action position via the plug-in manager for the plug-
ins which were loaded automatically from ‘cloapi_plugins’ folder or were
added from plug-in manager by user

Caution

Please keep in mind that the user edits the plug-in position via step 2), it
would discard the default position described in the plug-in dli(or dylib) file. It
means that the priority of the user modification is higher than the plug-in
developers’; and the key value for the decision is the plug-in dll(or dylib) file
path — absolute file path.

As this can make users confused as illustrated below, please be careful.

I. A developer wrote the default position inside ‘plug_in.dlIl’

il. A user saves the ‘plug_in.dIl' into the ‘cloapi_plugins’ folder or a
desirable folder, adds the plug-in and modifies the position

iii. The developer changes the default position inside ‘plug_in.dIl" and
distributes it to the user again.

19
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V. If the user puts the latest ‘plug_in.dIl’ into the same directory he or she
used in ii) and overwrites it, the plug-in menu will be located in the
position the user set in ii).

Plug-in Debug Logs

Plug-in log will be made in (CLO_ASSET_FOLDER)/api_plugin_log.txt when
trying to run the plug-in action from the file menu.

CLO_ASSET_FOLDER

Windows
C:\Users\Public\Documents\CLO\Assets\
Mac CLO_ASSER_FOLDER

~/Documents/clo/Assets/
Debug logs
MESSAGE_PLUGIN_ACTION_MENU_CLICKED: "User clicked to run a plug-in action."

MESSAGE_PLUGIN_ACTION_TRYING_TO_FIND_REGISTERED_DLL_PATH: "Module
starts to look up the registered plug-in file path for the plug-in action."

MESSAGE_PLUGIN_ACTION_SUCCESS_TO_FIND_REGISTERED_DLL_PATH:
"Succeeded to look up the registered plug-in file path for the plug-in action."

MESSAGE_PLUGIN_ACTION_FAILURE_TO_FIND_REGISTERED_DLL_PATH: "Failed to
look up the registered plug-in file path for the plug-in action."

MESSAGE_PLUGIN_ACTION_TRYING_TO_FIND_LOADED_PLUG_IN_DLL_FILE:
"Checking if the plug-in file has been loaded or not."

MESSAGE_PLUGIN_ACTION_SUCCESS TO_FIND_LOADED PLUG_IN_DLL_FILE: "The
plug-in has been loaded in the plug-in manager."”

MESSAGE_PLUGIN_ACTION_TRYING_TO_LOAD_PLUG_IN_DLL_FILE: "Trying to load
the plug-in file."

MESSAGE_PLUGIN_ACTION_SUCCESS_TO_LOAD_PLUG_IN_DLL_FILE: "The plug-in
file is loaded into the plug-in manager successfully."

MESSAGE_PLUGIN_ACTION_FAILURE_TO_LOAD_PLUG_IN_DLL_FILE: "Failed to load
the plug-in file."

MESSAGE_PLUGIN_ACTION_FAILURE_TO_LOAD_PLUG_IN_DLL_FILE_AND_ABORT:
"Failed to load the plug-in file. Aborted."

MESSAGE_PLUGIN_ACTION_TRYING_TO_FIND_DO_FUNCTION: "Trying to find
DoFunction inside the plug-in file."

20
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MESSAGE_PLUGIN_ACTION_SUCCESS_TO_LOAD_DO_FUNCTION: "Succeeded."
MESSAGE_PLUGIN_ACTION_FAILURE_TO_LOAD DO_FUNCTION: "Failed."

MESSAGE_PLUGIN_ACTION_TRYING_TO_EXECUTE_DO_FUNCTION: "Trying to run the
DoFunction inside the plug-in file."

MESSAGE_PLUGIN_ACTION_SUCCESS_TO_EXECUTE_DO_FUNCTION = "Succeeded."

MESSAGE_PLUGIN_ACTION_EXEPCTION_TO_EXECUTE_DO_FUNCTION =
"Exception.”

21



